WorldEdit plugin on FTB server

Discussion in 'Troubleshooting Suggestions' started by Sportyspike, Dec 18, 2015.

  1. Sportyspike

    Sportyspike New Member

    Hello!

    I am having trouble activating Worldedit on my FTB bisect server. I initially went through the plugins which gave me 'worldedit-bukkit-6.1'jar. I did think that was the first issue since FTB works with Forge. (if I am not mistaken). So then I removed that plugin and used the FTP to upload 'worldedit-forge-mc1.7.10'jar.

    I am definitely opped, I have tried using worldedit in survival, creative modes. Nothing will come up that says it is activated. I simply get 'Unknown command'.

    i've tried /wand, //wand, /jumpto, etc, etc, etc.

    Looking at the Worldedit quick start, I don't see anything that I am missing.

    All help is appreciated.
    thank you!

    Edit: I realize some of my previous info was mixed up (wrong). if i understand correctly, bukkit is the version for a server and forge is for single player. having said that, i have tried both and various versions of each .jar file.
    Nothing seems to happen. I cannot find error messages either. It would seem like plugins just aren't recognized.
     
    Last edited: Dec 25, 2015
  2. Kathars1s

    Kathars1s New Member

    Not sure if this is still relevant for you, but:

    I'm by no means an expert, as my FTB server here is only a month old now, but I have done a good bit of messing around and have gotten WorldEdit to work on FTB Horizons II Daybreaker, which is likely similar to what you're doing.

    I tried using Cauldron and the Bukkit WorldEdit without much luck. Cauldron made the server very unstable. So I went with the Forge mod WorldEdit.

    It's not that forge is for single player only, it just gets it to run natively as a mod, rather than attach on as a plugin, thus requiring you to install it locally as well as on the server.

    The download I used for WorldEdit on my server was: http://minecraft.curseforge.com/projects/worldedit/files/2219060

    Use the FTP and drop that into your mods folder as you would any other mod, then reboot your server.
    You also need to put it in your mods folder in your local installation. It does not run as a server only mod. You can join fine without it but will not have access to any of the commands.

    As soon as I installed it locally as well, it worked without a hitch.

    I havent tried wand or jumpto, but cut, copy, paste, rotate, all the brushes, and all the masks work fine.

    edit~ It's worth noting, WorldEdit 6.1 is for minecraft 1.8, and 6.0 is for 1.7.10. I'm not sure what FTB pack you are using, but should use the matching version. The above version I linked was for minecraft 1.7.10

    Here is forge for minecraft 1.8: http://minecraft.curseforge.com/projects/worldedit/files/2240310
     
    RangerMan likes this.

Share This Page